Ten Thumbs Online Typing Test

Java 1.1 Support Required
If the Ten Thumbs Online Typing Test does not start properly, you probably do not have Java 1.1 installed and/or enabled in your web browser.

Is your browser compatible with Java?
The typing test needs a Java 1.1 compatible browser, like Internet Explorer 4.0 or newer or Netscape Navigator 4.06 or newer or Safari (all versions) or Firefox (all versions). If you have an older browser, simply install a newer version to get Java support.

Is Java enabled in your browser?
Your browser security settings may prevent Java applets from running. To set the proper security preferences in your browser, look in the browser Preferences or Options dialogs for an option called "Enable Java". Ensure this is switched on.

Do you have Java installed?
If you do not have Java installed, you can download the latest version of Java from Sun Microsystems.